Resolved: Maintenance window has completed successully
Identified: We will be doing server maintenance but also upgrading to the new version of Test Track. The maintenance window covers 12th July 2025 @ 10am UTC to 3pm UTC. During this time Test Track will be unavailable. This is a very rare circumstance where we need to take Track offline for this release. The new version of Test Track includes the following improvements and feature changes: - Ability to delete all test plan steps even when used in a test run - Comment badge fix - 2FA Support - Login via SSO (Social Sign on) - Improved detection for Flaky Test Detection - Improvements to automated test run submission - Adding prerequisites for a test plan that are copied to a test run - Improved project selector - Improvements to task status with rare bug - Adding attachments to test plan For more detailed information about what's new in Test Track. check out our blog post at https://blog.devsosoftware.com/new-test-track-release-built-from-the-ground-up